null51CTO博客 - 牛牛娱乐

null51CTO博客

2019-01-03 10:41:49 | 作者: 景逸 | 标签: | 浏览: 2307


个人了解,6VPE(IPv6*** Provider Edge)是承载IPv6的MPLS***,是在坚持原有MPLS BGPv4主干不做大变动的状况下,一种IPv6 MPLS ***过渡技能。根本布置进程如下:PE与CE之间存在IPv6 VRF,树立BGPv6的街坊联系;PE与RR之间能够树立IPv6的BGP街坊联系,也能够树立IPv4街坊联系,同步仿制***v4地址族到***v6地址族中,其他装备跟IPv4的MPLS ***没有什么大差异。

以下为实验室测验环境下布置6VPE事例实战剖析:

环境介绍:

1、R1为某思科IOX设备、R4为某华为设备、R2和R3为某思科IOS设备;

2、地址散布:

R1

g0/1/1/2.10

12.1.1.1/30

2001:1::7/127

R4

g1/0/5.10

34.1.1.2/30

2001:1::2/126


g0/1/1/1

14.1.1.1/30


g1/0/7

14.1.1.2/30


Loopback0

1.1.1.1/32


Loopback0

4.4.4.4/32

R2

g3/0/2.10

12.1.1.2/30

2001:1::6/127

R3

g2/0/4.10

34.1.1.1/30

2001:1::1/126


Loopback0

2.2.2.2/32


Loopback0

3.3.3.3/32


Loopback6

2010:2::1/128


Loopback6

2010:3::1/128

3、拓扑图

4、R1与R3之间是EBGP互联,R4与R2之间是EBGP互联,R1与R4之间的IBGP协议为ISIS

实战布置进程出现:

1、    IPv4的MPLS ***根底环境布置

关于R2与R3两台思科IOS设备布置BGP,能够参阅我的其他博客文章,这儿要点罗列下R1与R4之间装备的状况。

(1)  R1与R4之间完成ISIS互通

R1:

router isis1000

 is-type level-2-only

 net 49.0010.0000.0000.0001.00

 log adjacency changes

 address-family ipv4 unicast

  metric-style wide//这个有必要metric格局有必要为wide

interface Loopback0

  circuit-type level-2-only

  address-family ipv4 unicast

interface GigabitEthernet0/1/1/1

  circuit-type level-2-only

  address-family ipv4 unicast

(接口与ISIS进程绑定,IOX是在ISIS进程下进程下进行的,这一点跟IOS和下面的华为设备不太相同)

R4

isis 1000

 is-level level-2

 cost-style wide

 network-entity 49.0010.0000.0000.0004.00

 traffic-eng level-2

 log-peer-change

###############################################################################

interface LoopBack0

 description For Global Routing

 ip address 4.4.4.4 255.255.255.255

 isis enable 1000

 isis circuit-level level-2

interface GigabitEthernet1/0/7

 description To-R1-GSR

 undo shutdown

 ip address 14.1.1.2 255.255.255.252

 isis enable 1000

 isis circuit-level level-2

(2)  R1与R4树立MPLS IBGP

R1#show run |be bgp

router bgp4809

 bgp router-id 1.1.1.1

 address-family ipv4 unicast

  redistribute connected

  redistribute static

address-family ***v4 unicast

neighbor 4.4.4.4

  remote-as 4809

  update-source Loopback0

  address-family ***v4 unicast

   next-hop-self

(IOX不需要再address-familyipv4地址族下树立街坊联系,只需要在***v4地址树立街坊联系即可)

R4

bgp 4809

 router-id 4.4.4.4

 peer 1.1.1.1 as-number 4809

 peer 1.1.1.1 connect-interface LoopBack0

ipv4-familyunicast                     

  undo synchronization

  import-route direct

  import-route static

  peer 1.1.1.1 enable

  peer 1.1.1.1 next-hop-local

(这儿也能够修正为undo peer 1.1.1.1 enable也是能够的)

ipv4-family***v4

  policy ***-target

  peer 1.1.1.1 enable

  peer 1.1.1.1 next-hop-local

(与IOX互联时,这儿IPv4-family街坊也能够不需要树立的)

(3)R1与R4树立LDP街坊联系

R1

mpls ldp

 router-id 1.1.1.1

 interface GigabitEthernet0/1/1/1

(IOX相同也是在MPLSLDP进程下将接口也放进来完成LDP与物理接口的绑定)

R4

mpls lsr-id4.4.4.4//华为设备在大局下启用MPLS时无法修正lsr-id,只要封闭mpls时才能够修正)

 mpls

mpls ldp//华为设备在大局下启用MPLS时,才能够修正MPLS Ldp

interface GigabitEthernet1/0/7

mpls

 mpls ldp

(接口下也是相同,只要先启用MPLS时,才能够启用MPLS ldp,且只要在大局下启用MPLS ldp状况下,接口下才能够收效)

(4)验证

R2#ping 3.3.3.3  

(3)  Typeescape sequence to abort.

Sending 5,100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:

!!!!!

Success rateis 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

2、6VPE布置

(1)R1与R4之间MPLS ***v6树立

R1

router bgp4809

 bgp router-id 1.1.1.1

 address-family ipv4 unicast

  redistribute connected

  redistribute static

address-family ***v4 unicast

address-family ***v4 unicast

address-family ipv6 unicast

address-family ***v6 unicast

 neighbor 4.4.4.4

  remote-as 4809

  update-source Loopback0

  address-family ***v4 unicast

   next-hop-self

  address-family ***v6 unicast

   next-hop-self

(IOX的装备很简单,即在v4街坊进程下添加赤色部分即***v6地址族罢了)

R4

bgp 4809

 router-id 4.4.4.4

peer 1.1.1.1as-number 4809

 peer 1.1.1.1 connect-interface LoopBack0

ipv4-family unicast

  undo synchronization

  peer 1.1.1.1 enable

  peer 1.1.1.1 advertise-community

ipv6-family unicast

  undo synchronization                   

  peer 1.1.1.1 enable

  peer 1.1.1.1 advertise-community

ipv4-family ***v4

  policy ***-target

  peer 1.1.1.1 enable

  peer 1.1.1.1 next-hop-local

ipv6-family ***v6

  policy ***-target

  peer 1.1.1.1 enable

  peer 1.1.1.1 next-hop-local

(华为的装备也比较简单,在ipv6地址族和***v6地址族下将ipv4地址族和***v4地址族下装备仿制一份张贴过来即可)

(2)R1与R4之间的ISIS、LDP街坊都不需要做任何改动

(3)R1与R2之间、R3与R4之间的IPv6 VRF相关装备与IPv4VRF装备迥然不同,仅有差异相应的修正下IPv4地址为IPv6罢了,这儿不做负担。

(4)成果验证

R2#show bgp ipv6

BGP tableversion is 8, local router ID is 2.2.2.2

Status codes:s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes:i - IGP, e - EGP, ? - incomplete

 

   Network          Next Hop            Metric LocPrf Weight Path

*>2001:1::/126     2001:1::7                              0 4809 ?

*  2001:1::6/127    2001:1::7                0             0 4809 ?

*>                  ::                       0        32768 ?

*>2001:2::2/128    ::                       0         32768 ?

*>2010:2::1/128    ::                       0         32768 i

*>2010:3::1/128    2001:1::7                              0 4809 64863 i

R2#ping 2010:3::1

 

Type escapesequence to abort.

Sending 5,100-byte ICMP Echos to 2010:3::1, timeout is 2 seconds:

!!!!!

Success rateis 100 percent (5/5), round-trip min/avg/max = 0/0/0 ms

 


版权声明
本文来源于网络,版权归原作者所有,其内容与观点不代表牛牛娱乐立场。转载文章仅为传播更有价值的信息,如采编人员采编有误或者版权原因,请与我们联系,我们核实后立即修改或删除。

猜您喜欢的文章